Welcome to Crossvale

Before you can register here on the website, you must first login to our network at PLAY.CROSSVALE.NET with your Minecraft character.

Sign Up

Minecraft 1.10

Discussion in 'News & Annoucements' started by RunsWithShovels, Jun 15, 2016.

  1. RunsWithShovels

    RunsWithShovels Administrator
    OWNER

    Joined:
    Jan 20, 2016
    Messages:
    43
    Likes Received:
    5
    **EDIT: The Network has been updated to Minecraft 1.10, please download the client to connect. If you have any issues please let a staff member know.

    With the recent release of Minecraft 1.10, the great developers of Spigot have released Spigot 1.10

    We never did a full update to 1.9 and we're currently using a protocol hack to allow 1.8-1.9 clients to connect to the network because we wanted to gauge what the players wanted. There was a lot of positive and negative feedback across the board on whether or not to stay on 1.8 or go to 1.9.

    So with this latest update rolling out from Spigot, we are working to move the network to Minecraft 1.10. This is for a few reasons. With most Minecraft releases, a large portion of plugin developers do not update their plugins in an expedient manner, but with 1.10 being released only this week, a majority of those have already updated the plugins to work with it. Another reason is that eventually the older versions of Minecraft will not be supported much longer and we'll lose operability. We want to make an attempt to stay on top of things and keep a fresh network for the loyal players.

    Please, if anyone has any issues during the time of upgrade, don't hestitate to let a staff member know. We will make all attempts to resolve it you.

    Thanks ~Shovels
     
    #1
    Last edited: Jun 16, 2016

Share This Page